Merge queue delays caused by a GitHub incident

Incident Report for Mergify Status Page

Resolved

GitHub's incident is resolved and Mergify is back to normal.
Merge queue processing returned to its usual rate.

Pull requests queued during the incident were processed as GitHub recovered, and no action is needed on your side.
Posted Aug 18, 2026 - 06:25 UTC

Identified

GitHub is currently experiencing degraded service on its API and webhook
delivery. Their incident is public and you can follow it at
https://www.githubstatus.com.

This is slowing merge queue processing across Mergify. Since around 13:30 UTC,
pull requests are taking longer than usual to be evaluated and merged, and some
events from GitHub are reaching us with delay.

Your pull requests stay in the queue. There is no need to re-queue them or to
change your configuration. Processing catches up as GitHub recovers.

We are monitoring and will update this page when the situation changes.
Posted Aug 17, 2026 - 13:55 UTC
This incident affected: Engine.