Unexpected merge queue notifications in Slack

Incident Report for Mergify Status Page

Resolved

This issue is now resolved.
Posted Jun 11, 2026 - 14:06 UTC

Identified

An issue is causing some Slack channels connected to Mergify to receive unexpected merge queue notifications, starting today at 13:14 UTC. Only notification delivery is affected — merge queues, pull request processing, and your data are operating normally.

We have identified the cause and a fix is in progress and is being rolled out.

We will post another update once the fix is fully deployed. We apologize for the noise in your channels.
Posted Jun 11, 2026 - 13:46 UTC