The fix has been deployed and the duplicate queue status comments issue is now resolved. Pull requests will no longer receive multiple status report comments per queue cycle.
Posted Mar 05, 2026 - 14:17 UTC
Monitoring
Comment duplication has been mitigating, we're still investigating the issue.
Posted Mar 05, 2026 - 12:42 UTC
Identified
We identified an issue where the merge queue was posting duplicate status report comments on pull requests. Instead of updating a single status comment per queue session, the system created a new comment on each queue cycle, resulting in a spam of comments on affected PRs.
A fix is being deployed. Once applied, duplicate comments will stop. Existing duplicate comments are cosmetic and do not affect merge queue behavior or merging.