Engine may have some difficulty to create merge-queue pull request

Incident Report for Mergify Status Page

Postmortem

We wrote an blog post about this incident: https://blog.mergify.com/handling-unexpected-third-part-change/

Posted Apr 28, 2022 - 17:08 UTC

Resolved

The issue has been solved.
Posted Apr 10, 2022 - 07:49 UTC

Monitoring

We've released a workaround for the issue. We're waiting to see if it has worked.
Posted Apr 10, 2022 - 07:05 UTC

Identified

We've spotted that something has gone wrong. GitHub does not always delete merge-queue pull request when its branch is deleted. This has been escalated to GitHub. We're currently working on a workaround, and will provide an update soon.
Posted Apr 09, 2022 - 06:48 UTC
This incident affected: Engine.