Merge Queue Processing Delays

Incident Report for Mergify Status Page

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 12:52 UTC

Monitoring

We mitigated the issue, the processing is working again.
Posted Jul 14, 2026 - 12:40 UTC

Investigating

Our merge queue processing is very slow for some customers.
Posted Jul 14, 2026 - 12:05 UTC
This incident affected: Engine.