Long-term fix has been deployed and is working as expected. All systems are operational.
Posted Sep 04, 2026 - 11:21 UTC
Update
The backlog recovered for all users. We are still monitoring the situation.
Posted Sep 04, 2026 - 10:03 UTC
Monitoring
The backlog recovered for almost all users. We are still monitoring the situation.
Posted Sep 04, 2026 - 09:30 UTC
Identified
Our GitHub event processing is running behind for some customers which cause unexpected latency latency in our Workflow Automation and Merge Queue pickup.