Delayed pull request processing

Incident Report for Mergify Status Page

Resolved

Issue is mitigated. If a pull request still looks stuck, comment "@mergifyio refresh" on it.
Posted Sep 16, 2026 - 17:42 UTC

Investigating

You may see this as Mergify not reacting to activity on your pull requests, so merge queues can stall and rules or checks may not update. The dashboard may fail to load, and API requests, including test result uploads from CI, may return errors.

This causes delays, not incorrect merges: a pull request Mergify has not been able to fully evaluate is held rather than merged. Some activity during these periods may not have reached Mergify.
Posted Sep 16, 2026 - 16:31 UTC
This incident affected: GitHub Events Processing and Merge Queue.