engine processing delays

Incident Report for Mergify Status Page

Resolved

The issue was impacted only a couple of customers and has been mitigated.
Posted Jul 08, 2026 - 17:54 UTC

Investigating

Some customers are experiencing some engine processing slowdown. We are investigate the issue.
Posted Jul 08, 2026 - 16:38 UTC
This incident affected: Engine.