Merge Queue Disruption

Incident Report for Mergify Status Page

Resolved

The incident affecting merge queue operations has been resolved.

The issue was caused by a transient surge of 404 Branch not found responses returned by GitHub APIs, which temporarily impacted branch processing and merge queue execution.

The errors have subsided and merge queue operations are now functioning normally.

We continue to monitor the situation closely.
Posted May 28, 2026 - 13:44 UTC

Investigating

We are currently experiencing a disruption affecting merge queue operations.

On our side, we are observing a surge of 404 Branch not found responses from GitHub APIs, which is impacting branch processing and merge queue execution.
We are actively investigating the issue and monitoring GitHub API behavior closely.

We will provide updates as more information becomes available.
Posted May 28, 2026 - 13:36 UTC
This incident affected: GitHub API Requests (githubstatus.com).