GitHub events processing

Incident Report for Mergify Status Page

Resolved

The GitHub events backlog have fully recovered
Posted Sep 02, 2026 - 21:20 UTC

Update

The backlog recovered for almost all users. We are still monitoring the situation.
Posted Sep 02, 2026 - 20:34 UTC

Monitoring

The GitHub events automatically recovered.
98% of impacted users already fully recovered. The GitHub events backlog continue to decreased for remaining users.
Posted Sep 02, 2026 - 19:21 UTC

Identified

Our GitHub event processing is running behind for some customers which cause unexpected latency latency in our Workflow Automation and Merge Queue pickup.
Posted Sep 02, 2026 - 18:12 UTC
This incident affected: Engine.