We have deployed a fix and test metrics processing has resumed. No data has been lost. Test results recorded throughout the incident were stored normally and will appear once processing catches up.
Posted Sep 15, 2026 - 16:06 UTC
Identified
We identified the issue and are working on a fix to release the congestion point.
Posted Sep 15, 2026 - 13:59 UTC
Investigating
Our data processing infrastructure is running behind which is causing delays while ingesting test metrics. No data has been lost.