We are continuing to monitor for any further issues.
Posted May 16, 2025 - 12:06 UTC
Monitoring
Our cloud provider has resolved the underlying network issue. As a result:
* Our dashboard is now fully operational. * Our processing engine is recovering and working through its backlog.
We are continuing to monitor the situation and will post a final update once full recovery is confirmed.
Thank you for your understanding.
Posted May 16, 2025 - 09:38 UTC
Update
We are currently experiencing an incident that is affecting the availability/performance of our services. The issue has been traced to a broader incident on our cloud hosting provider’s network, which is impacting multiple services.
We are working on a workaround.
We actively monitor the situation and will provide updates as we receive more information from our provider or when our workaround is ready.
Thank you for your patience.
Posted May 16, 2025 - 07:36 UTC
Update
We are continuing to investigate this issue.
Posted May 16, 2025 - 07:08 UTC
Investigating
We've spotted an issue with our dashboard and our events processing. We're currently investigating the issue, and will provide an update soon.